Third Light Developer Exchange

Code and templating community forum for developers and software integrators

You are not logged in.

Announcement

If you wish to join the Developer Exchange, please contact your account manager - this is to avoid unnecessary spam in the forums. Many thanks for your understanding.

#1 2014-11-28 10:17:36

stevesmith
Member
Registered: 2014-11-25
Posts: 11

Cannot get AdvancedSearch to work

Hi,

Apologies for the re-post of this topic under a more sensible subject.

I'm trying get the following Advanced search to work but get the error : SEARCH_QUERY_FIELD_CONDITION_INVALID

$q='{"apiVersion":"1.0","sessionId":"'.$strSessionId.'","inParams":{"query":[{"fieldId":"1","conditionId":"0","value":"a"}]},"action":"Search.AdvancedSearch"}';

I've also tried using the full name for the fielId.

Any ideas ?

Thanks

Steve Smith

Offline

#2 2014-11-28 10:22:26

dominic
Third Light Staff
Registered: 2013-06-06
Posts: 96

Re: Cannot get AdvancedSearch to work

Hi Steve,

I don't think fieldId 1 is defined - what is it that you are trying to search on?

Dominic

Offline

#3 2014-11-28 10:25:49

stevesmith
Member
Registered: 2014-11-25
Posts: 11

Re: Cannot get AdvancedSearch to work

Hi Dominic,

In this practice example I'm was just trying everything with "a" in the title.

Steve Smith

Offline

#4 2014-11-28 10:39:51

stevesmith
Member
Registered: 2014-11-25
Posts: 11

Re: Cannot get AdvancedSearch to work

Sorry Dominic I misread the GetSearchConfiguration response.
I have it working now.

Thanks for you help.

Steve Smith

Offline

Board footer